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Lab - Mapping the Internet
Lab - Mapping the Internet
Objectives
Part 1: Test Network Connectivity Using Ping
Part 2: Trace a Route to a Remote Server Using Windows Tracert
Part 3: Trace a Route to a Remote Server Using Web-Based and Software Tools
Part 4: Compare Traceroute Results
Background
Route tracing computer software is a utility that lists the networks data has to traverse from the user's originating end device to a distant destination network.
This network tool is typically executed at the command line as:
tracert <destination network name or end device address>
(Microsoft Windows systems)
or
traceroute <destination network name or end device address>
(Unix and similar systems)
Route tracing utilities allow a user to determine the path or routes as well as the delay across an IP network. Several tools exist to perform this function.
The traceroute (or tracert) tool is often used for network troubleshooting. By showing a list of routers traversed, it allows the user to identify the path taken to reach a particular destination on the network or across internetworks. Each router represents a point where one network connects to another network and through which the data packet was forwarded. The number of routers is known as the number of "hops" the data traveled from source to destination.
The displayed list can help identify data flow problems when trying to access a service such as a website. It can also be useful when performing tasks such as downloading data. If there are multiple websites (mirrors) available for the same data file, one can trace each mirror to get a good idea of which mirror would be the fastest to use.
Two trace routes between the same source and destination conducted some time apart may produce different results. This is due to the "meshed" nature of the interconnected networks that comprise the Internet and the Internet Protocols ability to select different pathways over which to send packets.
Command-line-based route tracing tools are usually embedded with the operating system of the end device.
Other tools, such as VisualRoute™, are proprietary programs that provide extra information. VisualRoute uses available online information to graphically display the route.
This lab assumes the installation of VisualRoute. If the computer you are using does not have VisualRoute installed, you can download the program using the following link:
http://www.visualroute.com/download.html
If you have any trouble downloading or installing VisualRoute, ask your instructor for assistance. Ensure that you download the Lite Edition.
[image: VisualRoute Lite Edition]
Scenario
Using an Internet connection, you will use three route tracing utilities to examine the Internet pathway to destination networks. This activity should be performed on a computer that has Internet access and access to the command line. First, you will use the Windows embedded tracert utility. Second, you will use a web-based traceroute tool (http://www.subnetonline.com/pages/network-tools/online-traceroute.php). Finally, you will use the VisualRoute traceroute program.
Required Resources
1 PC (Windows 7, Vista, or XP with Internet access)
Test Network Connectivity Using Ping
Determine whether the remote server is reachable.
To trace the route to a distant network, the PC used must have a working connection to the Internet.
The first tool we will use is ping. Ping is a tool used to test whether a host is reachable. Packets of information are sent to the remote host with instructions to reply. Your local PC measures whether a response is received to each packet, and how long it takes for those packets to cross the network. The name ping comes from active sonar technology in which a pulse of sound is sent underwater and bounced off of terrain or other ships.
[bookmark: OLE_LINK13]From your PC, click the Windows Start icon, type cmd in the Search programs and files box, and then press Enter.
[image: ]
At the command-line prompt, type ping www.cisco.com.
[image: ping cisco com]
The first output line displays the Fully Qualified Domain Name (FQDN) e144.dscb.akamaiedge.net. This is followed by the IP address 23.1.48.170. Cisco hosts the same web content on different servers throughout the world (known as mirrors). Therefore, depending upon where you are geographically, the FQDN and the IP address will be different.
From this portion of the output:
[image: 4 pings]
Four pings were sent and a reply was received from each ping. Because each ping was responded to, there was 0% packet loss. On average, it took 54 ms (54 milliseconds) for the packets to cross the network. A millisecond is 1/1,000th of a second.
Streaming video and online games are two applications that suffer when there is packet loss, or a slow network connection. A more accurate determination of an Internet connection speed can be determined by sending 100 pings, instead of the default 4. Here is how to do that:
[image: 100 pings]
And here is what the output from that looks like:
[image: 100 pings summary]
Now ping Regional Internet Registry (RIR) websites located in different parts of the world:
For Africa:
C:\> ping www.afrinic.net
[image: ping www afrinic net]
For Australia:
C:\> ping www.apnic.net
[image: Australia ping  www apnic net]
For Europe:
C:\> ping www.ripe.net
[image: Europe ping]
For South America:
C:\> ping lacnic.net
[image: ping www lacnic net]
All these pings were run from a computer located in the U.S. What happens to the average ping time in milliseconds when data is traveling within the same continent (North America) as compared to data from North America traveling to different continents?
____________________________________________________________________________________
What is interesting about the pings that were sent to the European website?
____________________________________________________________________________________
Trace a Route to a Remote Server Using Tracert
Determine what route across the Internet traffic takes to the remote server.
Now that basic reachability has been verified by using the ping tool, it is helpful to look more closely at each network segment that is crossed. To do this, the tracert tool will be used.
At the command-line prompt, type tracert www.cisco.com.
[image: tracert www cisco com]
Save the tracert output in a text file as follows:
Right-click the title bar of the Command Prompt window and choose Edit > Select All.
Right-click the title bar of the Command Prompt window again and choose Edit > Copy.
Open the Windows Notepad program: Windows Start icon > All Programs > Accessories > Notepad.
To paste the output into Notepad, choose Edit > Paste.
Choose File > Save As and save the Notepad file to your desktop as tracert1.txt.
Run tracert for each destination website and save the output in sequentially numbered files.
C:\> tracert www.afrinic.net
C:\> tracert www.lacnic.net
Interpreting tracert outputs.
Routes traced can go through many hops and a number of different Internet Service Providers (ISPs), depending on the size of your ISP and the location of the source and destination hosts. Each “hop” represents a router. A router is a specialized type of computer used to direct traffic across the Internet. Imagine taking an automobile trip across several countries using many highways. At different points in the trip you come to a fork in the road in which you have the option to select from several different highways. Now further imagine that there is a device at each fork in the road that directs you to take the correct highway to your final destination. That is what a router does for packets on a network.
Because computers talk in numbers, rather than words, routers are uniquely identified using IP addresses (numbers with the format x.x.x.x). The tracert tool shows you what path through the network a packet of information takes to reach its final destination. The tracert tool also gives you an idea of how fast traffic is going on each segment of the network. Three packets are sent to each router in the path, and the return time is measured in milliseconds. Now use this information to analyze the tracert results to www.cisco.com. Below is the entire traceroute:
[image: tracert www cisco com]
Below is the breakdown:
[image: hop 1 and 2 tracert www cisco com]
In the example output shown above, the tracert packets travel from the source PC to the local router default gateway (hop 1: 192.168.1.1) to the ISPs Point of Presence (POP) router (hop 2: 10.18.20.1). Every ISP has numerous POP routers. These POP routers are at the edge of the ISP’s network and are the means by which customers connect to the Internet. The packets travel along the Verizon network for two hops and then jump to a router that belongs to alter.net. This could mean that the packets have traveled to another ISP. This is significant because sometimes there is packet loss in the transition between ISPs, or sometimes one ISP is slower than another. How could we determine if alter.net is another ISP or the same ISP?
There is an Internet tool known as whois. The whois tool allows us to determine who owns a domain name. A web-based whois tool is found at http://whois.domaintools.com/. This domain is also owned by Verizon according to the web-based whois tool.
[image: whois alter net edited]
To summarize, Internet traffic starts at a home PC and travels through the home router (hop 1). It then connects to the ISP and travels through its network (hops 2-7) until it arrives at the remote server (hop 8). This is a relatively unusual example in which there is only one ISP involved from start to finish. It is typical to have two or more ISP involved as displayed in the following examples.
Now examine an example that involves Internet traffic crossing multiple ISPs. Below is the tracert for www.afrinic.net:
[image: tracert  www afrinic net]
What happens at hop 7? Is level3.net the same ISP as hops 2-6, or a different ISP? Use the whois tool to answer this question.
____________________________________________________________________________________
What happens in hop 10 to the amount of time it takes for a packet to travel between Washington D.C. and Paris, as compared with the earlier hops 1-9?
____________________________________________________________________________________
____________________________________________________________________________________
What happens in hop 18? Do a whois lookup on 168.209.201.74 using the whois tool. Who owns this network?
____________________________________________________________________________________
____________________________________________________________________________________
Type tracert www.lacnic.net.
[image: tracert www lacnic net]
What happens in hop 7?
____________________________________________________________________________________
____________________________________________________________________________________
____________________________________________________________________________________
Trace a Route to a Remote Server Using Web-Based and SoftwareTools
Use a web-based traceroute tool.
Using http://www.subnetonline.com/pages/network-tools/online-tracepath.php to trace the route to the following websites:
www.cisco.com
www.afrinic.net
Capture and save the output in Notepad.
How is the traceroute different when going to www.cisco.com from the command prompt (see Part 1) rather than from the online website? (Your results may vary depending upon where you are located geographically, and which ISP is providing connectivity to your school.)
____________________________________________________________________________________
____________________________________________________________________________________
____________________________________________________________________________________
____________________________________________________________________________________
Compare the tracert from Part 1 that goes to Africa with the tracert that goes to Africa from the web interface. What difference do you notice?
____________________________________________________________________________________
____________________________________________________________________________________
____________________________________________________________________________________
Some of the traceroutes have the abbreviation asymm in them. Any guesses as to what this means? What is its significance?
____________________________________________________________________________________
____________________________________________________________________________________
____________________________________________________________________________________
Use VisualRoute Lite Edition
VisualRoute is a proprietary traceroute program that can display the tracing path results graphically.
Please download the VisualRoute Lite Edition from the following link if it is not already installed:
http://www.visualroute.com/download.html
If you have any trouble downloading or installing VisualRoute, ask your instructor for assistance. Ensure that you download the Lite Edition.
Using VisualRoute 2010 Lite Edition, trace the routes to www.cisco.com.
Record the IP addresses in the path in Notepad.
[image: traceroute www cisco com VisualRoute]
Compare Traceroute Results
Compare the traceroute results to www.cisco.com from Parts 2 and 3.
List the path to www.cisco.com using tracert.
____________________________________________________________________________________
____________________________________________________________________________________
List the path to www.cisco.com using the web-based tool on subnetonline.com.
____________________________________________________________________________________
____________________________________________________________________________________
List the path to www.cisco.com using VisualRoute Lite edition.
____________________________________________________________________________________
____________________________________________________________________________________
Did all the traceroute utilities use the same paths to www.cisco.com? Why or Why not?
_______________________________________________________________________________________
_______________________________________________________________________________________
_______________________________________________________________________________________
Reflection
Having now viewed traceroute through three different tools (tracert, web interface, and VisualRoute), are there any insights that using VisualRoute provided that the other two tools did not?
_______________________________________________________________________________________
_______________________________________________________________________________________
_______________________________________________________________________________________
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C:\>ping www.cisco.com

Pinging el44.dsch.akamaiedge.net [23.1.48.170] with 32 bytes of data
Reply from 23.1.48.170: bytes=32 time=S6ms TTL:57

Reply from 23.1.48.170: bytesz32 timez55ms
Reply from 23.1.48.170: bytes=32 tim
Reply from 23.1.48.170: bytes=32 tim

Ping statistics for 23.1.48.170:

Packets: Sent = 4, Received = 4, Lost = 8 (8% loss),
approximate round trip times in milli-seconds

Minimum = S4ms, Maximum = 56ms, Auerage = Sims
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Ping statistics for 23.1.48.170:
Packets: Sent = 4, Received = 4, Lost = 8 (8% loss),
Approximate round trip times in milli-seconds
Minimum = S4ms, Maximum = 56ms, Auerage = Sims
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C:\>ping -n 100 www.cisco.com
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Ping statistics for 23.45.0.170:
Packets: Sent = 100, Received = 100, Lost = 8 (8% loss),
approximate round trip times in milli-seconds
Minimum = 46ms, Maximum = 53ms, Auerage = 49ms
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C:\>ping www.afrinic.net

Pinging www.afrinic.net [196.216.2.136] with 32 bytes of data:
Reply from 196.216.2.136: bytes=32 time=314ms TTL=111

Reply from 196.216.2.136: 2 time=312ms
Reply from 196.216.2.136: 2 time=313ms
Reply from 196.216.2.136: 2 time=313ms

Ping statistics for 196.216.2.136:

Packets: Sent = 4, Received = 4, Lost = 8 (8% loss),
approximate round trip times in milli-seconds

Minimum = 312ms, Maximum = 314ms, Average = 313ms
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C:\>ping Www.apnic.net

Pinging www.apnic.net [202.12.29.194] with 32 bytes of data
Reply from 202.12.29.194: 2 time=286ms
Reply from 202.12.29.194: 2 time=287ns
Reply from 202.12.29.194: bytes=32 time:286ms
Reply from 202.12.29.194: bytes=32 time:286ms

Ping statistics for 202.12.29.194:

Packets: Sent = 4, Received = 4, Lost = 8 (8% loss),
approximate round trip times in milli-seconds

Minimum = 286ms, Maximum = 287ms, Average = 286ms
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C:\>ping www.ripe.net

Pinging www.ripe.net [193.0.6.139] with 32 bytes of data:
Request timed out.
Request timed out.
Request timed out.
Request timed out.

Ping statistics for 193.0.6.139:
Packets: Sent = 4, Received = O, Lost = 4 (100% loss),
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C:\>ping wwWwW.lacnic.net

Pinging wwwW.lacnic.net [200.3.14.147] with 32 bytes of data:
Reply from 200.3.14.147: bytes=32 time=158ms TTL=51
Reply from 200.3.14.147: bytes=32 time=158ms TTL=51
Reply from 200.3.14.147: bytes=32 time=158ms TTL=51
Reply from 200.3.14.147: bytes=32 time=157ms TTL=51

Ping statistics for 200.3.14.147:
Packets: Sent = 4, Received = 4, Lost = 8 (8% loss),
Approximate round trip times in milli-seconds
Minimum = 157ms, Maximum = 158ms, Average = 157ms
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C:\>tracert www.cisco.com

Tracing route to el44.dsch.akamaiedge.net [23.1.144.170]
over a maximum of 30 hops:

1 <lms <1ms <1 ms dslrouter.uestell.com [192.168.1.1]

2 38ms 38ms 37 ms 10.18.20.1

3 37Tms 37 ms 37 ms G3-0-9-2204.ALBYNY-LCR-02.verizon-gni.net [130.8
1.196.190]

4 43'ms 43 ms 42 ms so-5-1-1-0.NY325-BB-RTR2.uverizon-gni.net [130.81
.22.46]

5 43 ms 43 ms 65 ms 0.s0-4-0-2.XT2.NYC4.ALTER.NET [152.63.1.57]

6 45 ms 45 ms 45 ms 0.s0-3-2-0.XL4.EWRG.ALTER.NET [152.63.17.109]

7 46 ms 48 ms 46 ms TenGigE0-5-0-0.GWS.EWRG.ALTER.NET [152.63.21.14]

8 45 ms 45 ms 45 ms a23-1-144-170.deploy.akamaitechnologies.com [23.
1.144.170]

Trace complete.
\
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C:\>tracert www.afrinic.net

Tracing route to www.afrinic.net [196.216.2.136]
over a maximum of 30 hops

1 Tms <Ims <1 ms dslrouter.westell.com [192.168.1.1]

2 39ms  38ms 37 ms 10.18.20.

3 49 ms 38 ms 39 ms G4-0-0-2204.ALBYNY-LCR-02.verizon-gni.net [130.8
1.197.182]

4 44'ms 43 ms 43 ms so-5-1-1-8.NY325-BB-RTR2.verizon-gni.net [130.8
.22.46]

5 43 ms 43 ms 42 ms 0.s0-4-0-0.XT2.NYCH.ALTER.NET [152.63.9.249

6 43 ms 71 ms 43 ms 0.ae4.BR3.NYC4. ALTER.NET [152.63.16.185

7T 4Tms 4T ms 47 ms te-7-3-0.edge2.Newvork2.level3.net [4.68.111.137
1

8§ 43 ms 55 ms 43 ms ulanS1.ebrl.NewYork2.Level3.net [4.69.138.222

9 52ms 51 ms 51 ms ae-3-3.ebr2.Washingtonl.Level3.net [4.69.132.89

10 130 ms 132 ms 132 ms ae-42-42.ebr2.Parisl.Level3.net [4.69.137.53]
11 139 ms 145 ms 140 ms ae-46-46.ebr1.Frankfurtl.Level3.net [4.69.143.13

12 148 ms 140 ms 152 ms ae-91-91.csw4.Frankfurtl.Level3.net [4.69.140.14
13 144 ms 144 ms 146 ms ae-92-92.ebr2.Frankfurtl.Level3.net [4.69.140.29
14 151 ms 150 ms 150 ms ae-23-23.ebr2.Londonl.Level3.net [4.69.148.193]

15 150 ms 150 ms 150 ms ae-58-223.csw2.Londonl.Level3.net [4.69.153.138]

16 156 ms 156 ms 156 ms ae-227-3603.edge3.Londonl.Level3.net [4.69.166.
541

17 157 ms 159 ms 160 ms 195.50.124.3%

18 353 ms 340 ms 341 ms 168.209.201.74

19 333 ms 333 ms 332 ms cswi-pkl-gil-1.ip.isnet.net [196.26.6.101]

20 331 ms 331 ms 331 ms 196.37.155.180

21 318 ms 316 ms 318 ms fal-8-1.ar62.jnb.afrinic.net [196.216.3.132

22 332ms 33 ms 332 ms 196.216.2.136

Trace complete.
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C:\>tracert www.lacnic.net

Tracing route to www.lacnic

over a maximum of 38 hops

1 <
2 38ams
3 38ams
1.196.190]
4 42'ms
.22.46]
5 82ms
6 46 ms
7157 ms
8 156 ms
9 161 ms
10 158 ms
11 176 ms
12 158 ms
13 157 ms

Trace complete.
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